Knowledge Base

 

Unit is not working at all

Unit is not working at all- There is no electricity in the socket

  • Remove power supply from socket for 30 seconds.
  • Disconnect Robot and turn power supply on If not working, change to another socket.

Unit is not working at all- Floating cable might not be connected properly

Reconnect the floating cable into the power supply.

Unit is not working at all- Something obstructing the free movement of the Drive Belts, Drive Tracks or wheels

Flip the robot upside-down.
Try to rotate the wheels by hand.
Check for and remove any debris in the driving system such as hair, string or leaves.

Unit is not working at all- Propeller is seized due to accumulation of hair

Remove the top screws on the outlet top and check if the propeller needs to be cleaned.

  • Remove the robot from power before starting.

(When reassembling the top cover, use only manual tool.

DO NOT USE power-tool for this operation)

Unit is not working at all- Defective motor or pump.

Turn the Robot upside down, and try to turn it on – check if pump and motor start functioning.

Unit is not working at all- Power supply or Unit still not working

Send the unit to your service center.
Show more

Unit moves, but...

Unit moves but does not pump water- Filters are very dirty

Remove the filter, and run the robot without the filter. If working well - clean the filter well or replace filter.

Unit moves but does not pump water- Propeller is broken or seized due to accumulation of hair

Remove the top screws on the outlet top and check if the propeller is broken or need to be cleaned.

  • Remove the robot from power before starting.

(When reassembling the top cover, use only manual tool.

DO NOT USE power-tool for this operation)

Unit moves but does not pump water- Unit still not working properly

Send the unit to your service center.

Units start ok, and shut off after short time- Filters are dirty

Remove the filter, and run the robot without the filter. If working well - clean the filter well or replace filter.

Sometimes the filter is blocked but seems clean. Can clean by soaking in water+soap for 30 minutes and then gently scrub the surface from inside.

The Unit is standing on 2 wheels when start driving or during driving cycle- pool surface is too smooth

Reduce float on bottom lid or opposite to motor.

Make sure that PH is between 7.2 and 7.6 if not - make proper adjustments.

The Unit is standing on 2 wheels when start driving or during driving cycle- pool surface is rough

Send to service center to replace to PVC wheel.
Weitere laden

Unit does not move, but...

Unit does not move but does pump water- Obstacle prevents the wheels/belts from turning well

  • Rotate the wheels by hand.
  • Clean and remove Obstacles if necessary

Unit does not move but does pump water- Drive Track or internal rollers are worn

  • Check the internal teeth of the drive belts of both Master and Slave sides.
  • Bring to service if worn

Unit does not move but does pump water- Unit still not working properly

Send the unit to your service center.
Weitere laden

Unit not climbing the walls

The Unit does not climb walls- Filters are dirty

Remove the filter, and run the robot without the filter. If working well - clean the filter well.

Sometimes the filter is blocked but seems clean.

The Unit does not climb walls- Propeller is broken or seized due to accumulation of hair

Remove the top screws on the outlet top and check if the propeller is broken or need to be cleaned.

  • remove the robot from power before starting

(When reassembling the top cover, use only manual tool.

DO NOT USE power-tool for this operation)

The Unit does not climb walls- Chlorine level is not correct.

Check water Chlorine treatment, if water is not treated - need Shock Chlorine treatment.

Remove the robot from the pool during this treatment.

The Unit does not climb walls- PH level is not correct.

Make sure that PH is between 7.2 and 7.6 if not - make proper adjustments.

Remove the robot from the pool during this treatment.

The Unit does not climb walls- Water temperature is not optimal.

Check water temperature – if below 13°C add floats according to your robot model.

The Unit does not climb walls- The unit is not intended to climb.

Verify that your unit is not Floor-only model.

Ask customer to read robot part# on the sticker.

If includes - REFL the robot is not intended to climb.

The Unit does not climb walls- Unit still not climb the walls.

Send the unit to your service center.
Weitere laden

Remote control problem

Remote control does not work- The batteries are empty

Check The batteries by pressing the Buttons - the red light on the remote control unit will not flash if battery is empty.

Send new battery to customer if needed.

Remote control does not work- The remote does not match the power supply.

Match the remote with the power supply.

See Remote Control Manual.

Remote control does not work- Remote control still not working.

Send the unit to your service center.
Weitere laden

Problem with cable

The cable is tangled- Unclean filters may affect the unit movement.

Make sure all filters are clean.

The cable is tangled- Bottom lid is not properly closed.

Make sure the bottom lid is properly closed.

The cable is tangled- Cable is not spread out before entering the unit to the pool.

Make sure that the floating cable is properly spread out and is untangled.

The cable is tangled- Propeller is broken or seized due to accumulation of hair

Remove the top screws on the outlet top and check if the propeller is broken or need to be cleaned.

  • remove the robot from power before starting

(When reassembling the top cover, use only manual tool.

DO NOT USE power-tool for this operation).

The cable is tangled- There is too much cable in the water.

Verify that there is enough cable in the water to reach the far end of the pool but not more than that.

For example if the pool is 10 X 5 meters and the power supply is at the middle, put only 6 meters of cable into the pool.

The cable is tangled- Cable is still tangling

Send the unit to your service center.
Weitere laden

Brushes

PVA Brush is dissolving or abrasion fast- The unit was inside the water during a pool chemical treatment.

Verify to take robot our when making chemical treatment.

If the PVA Sponge is fully dissolved/destroyed – send the unit to your service center for replacement.

PVA Brush is dissolving or abrasion fast- Chlorine level is not correct.

Check water Chlorine treatment; make sure that the Chlorine level is not too high.

If the PVA Sponge is fully dissolved/destroyed – send the unit to your service center for replacement.

PVA Brush is dissolving or abrasion fast- PH level is not correct.

Make sure that PH is between 7.2 and 7.6 if not - make proper adjustments.

If the PVA Sponge is fully dissolved/destroyed – send the unit to your service center for replacement.

PVA Brush is dissolving or abrasion fast- Pool Surface is very rough (Cement / Gunite / Pebble)

Send the unit to your service center to Change PVA wheels to PVC Wheels.
Weitere laden

The robot stops after starting

Units start ok, and shuts off after short time- Propeller is seized due to accumulation of hair or debris.

Remove the top screws on the outlet top and check if the propeller needs to be cleaned.

  • remove the robot from power before starting.

(When reassembling the top cover, use only manual tool.

DO NOT USE power-tool for this operation)

Units start ok, and shut off after short time- Obstacle prevents the wheels/belts from turning well

  • Rotate the wheels by hand.
  • Clean and remove Obstacles if necessary.

Units start ok, and shut off after short time- Unit still not working properly

Send the unit to your service center.
Weitere laden

Debris collecting issues

Unit does not pick up dirt and debris- Filters are not thoroughly clean or have holes.

Clean as necessary and verify that there no holes in the filter.

Unit does not pick up dirt and debris- Propeller is broken or seized due to accumulation of hair

Remove the top screws on the outlet top and check if the propeller is broken or need to be cleaned.

  • remove the robot from power before starting.

(When reassembling the top cover, use only manual tool.

DO NOT USE power-tool for this operation)

Unit does not pick up dirt and debris- the Intake Valve Flaps are missing or stuck as a result of Obstacles

Check the Intake Valve Flaps on the underside of your unit.

The Flaps should move freely to open and close.

Clean and free the Valve Flaps if necessary.

 

Valve flaps location

In different models:

Unit does not pick up dirt and debris- The non-return valves are missing or stuck

Check the non-return valves on the unit.

The valves should be complete and cover the entire hole.

 

Non-return Valve location:

Debris comes out of the unit when removing It from pool- Bottom lid is not properly closed.

Make sure that the bottom lid is properly closed.

Debris comes out of the unit when removing It from pool- There are holes in the filters.

Verify that there are no holes in the filters, and that filter frame is complete.

Debris comes out of the unit when removing It from pool- the Intake Valve Flaps are stuck as a result of Obstacles or Missing.

Check the Intake Valve Flaps on the underside of your unit.

The Flaps should move freely to open and close.

Clean and free the Valve Flaps if necessary.

 

Valve flaps location

In different models:

Debris comes out of the unit when removing It from pool- Debris still comes out.

Send the unit to your service center.
Weitere laden

Pool coverage problems

Unit does not seem to cover the entire pool- There is not enough cable in the water to reach the far end of the pool, or the cable is too tangled.

Verify that there is enough cable in the water to reach the far end of the pool but not more than that.

Make sure that the floating cable is properly spread out and is untangled.

Unit does not seem to cover the entire pool- The angle of the units handle may affect the unit movement in the water.

Increase diagonal Angle of the handle by pressing the handle pin and move it in opposite directions.

Unit does not seem to cover the entire pool- PH level is not correct.

Make sure that PH is between 7.2 and 7.6

if not - make proper adjustments.

 

Remove the robot from the pool during this treatment.

Unit does not seem to cover the entire pool- Chlorine level is not correct.

Check water Chlorine treatment, if water is not treated - make Shock Chlorine treatment.

Remove the robot from the pool during this treatment.

Unit does not seem to cover the entire pool- Propeller is broken or seized due to accumulation of hair

Remove the top screws on the outlet top and check if the propeller is broken or need to be cleaned.

*remove the robot from power before starting.

(When reassembling the top cover, use only manual tool.

DO NOT USE power-tool for this operation).

Unit does not seem to cover the entire pool- Some obstacle stuck in the driving system.

Try to rotate the wheels by hand.

Clean and remove Obstacles from the driving system as necessary.

Unit does not seem to cover the entire pool- Unit still not cover the entire pool.

Send the unit to your service center.
Weitere laden